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Chapter5
Opening Data Files

REMEMBER

ou don’t need to put your data into the computer more than once. If you

have your data in another program, you can import it from there into

SPSS — because every program worth using has some form of output that
can serve as input to SPSS. This chapter discusses ways to transfer data into and
out of SPSS.

Sometimes you won’t get variable names when you import data from other soft-
ware, but you can fix that problem in variable view.

Getting Acquainted with the
SPSS File Format

SPSS uses its own format, the .sav extension, for storing data and writing files.
The file format contains special codes and usually can’t be used to export your
data to another application. Instead, the file format is used only for saving SPSS
data that you want to read back into SPSS at a later time.

The tremendous advantage of using SPSS data format is that it contains not only
the cases and variables but also the metadata. For every other type of file that you
bring into the software, you’ll need to go back to the variable view to set up the
metadata, as explained in Chapter 4.
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WARNING

TIP

Several example files in this format are copied to your computer as part of the
normal SPSS installation. These files are in the same directory as your SPSS instal-
lation. To load one of these files, choose File &> Open = Data and select the file to
be loaded. When you do so, the variable names and data are loaded into SPSS.

If you have data in SPSS, you can save it as a .sav file by choosing File => Save As
and providing a name for the file. Or if you’ve loaded the information from a file,
or previously saved a copy of the information to a file, simply choose File &> Save
to overwrite the previous file with a fresh copy of both variable definitions
and data.

It’s easy to be fooled by the way the SPSS documentation uses the word file. If
you’ve defined data and variables in your program, SPSS documentation often
refers to it all as a file, even though it may never have been written to disk. SPSS
also refers to the material written to disk as a file, so watch the context.

When you write your file to disk, if you don’t add the .sav extension to the file-
name; SPSS adds it for you. When you choose File = Open = Data to display the
list of files, you may not see the filename extension (depending on how your Win-
dows system is configured), but it’s there.

When you drag a data file to the SPSS Data Editor window, SPSS chooses the
appropriate format and begins reading the data file.

Reading Simple Data from a Text File

60

This section contains an example of a procedure you can follow to read data from
a simple text file into SPSS. The example reads this text file and inserts it into the
cells of SPSS. Along the way, SPSS keeps you informed about what’s going on so
there won’t be any big surprises at the end.

Follow these steps:

1. chooseFile = Import Data > Text Data.
The file is in the SPSS installation directory.
2. Select the demo.txt file, and then click Open.

The Text Import Wizard appears, as shown in Figure 5-1, allowing you to load
and format your data.
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FIGURE 5-1:
Make sure your
data looks
reasonable.

(] Text Import Wizard - Step 1 of 6

Welcome to the text import wizard!

This wizard will help you read data from your text
file and specify information about the variables.

Does your text file match a predefined format? —

| 1§ |Oves | (Browse...|

wlulnla

®iNo|

Text file: /Users/jesussalcedo/Desktop/SPSSStatisticsForDummies/Curr...

0 10 20 30 40 50
Name| | age marital address income inccat car carcat ed q
2| [55 1 12 72 3 37 3 1
3| [56 ] 29 153 4 76 3 1
41 28 1 9 28 2 14 1 3
51 [24 1 4 26 2 13 1 4
6| 25 1 2 23 1 11 1 2 [+
T — I

3.

o

N o

Examine the input data.

The screen lets you peek at the contents of the input file so you can verify
that you've chosen the right file. Also, if your file uses a predefined format
(it doesn't in this example), you can select it here and skip some of the later
steps. If your data doesn't show up nicely separated into values the way you
want, you may be able to correct it in a later step. Don't panic just yet.

Click Continue.

Specify that the data is delimited and the names are included, as shown
in Figure 5-2.

As you can see in this example, SPSS takes a guess, but you can also specify
how your data is organized. It can be divided using spaces (as in this example),
commas, tabs, semicolons, or some combination. Or your data may not be
divided — it may be that all the data items are jammed together and each has
a fixed width. If your text file includes the names of the variables, you need to
tell SPSS.

Click Continue.
Specify how SPSS should interpret the text.

For this example, the correct settings are shown in Figure 5-3. You can tell SPSS
something about the file and which data you want to read.

Perhaps some lines at the top of the file should be ignored — this happens
when you're reading data from text intended for printing and header informa-
tion is at the top. By telling SPSS about it, those first lines can be skipped.
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FIGURE 5-2:
Specify whether
the fields are
delimited and
whether the
variable names
are included.

FIGURE 5-3:
Specify where
the data appears
in the file.

0 Text Import Wizard - Step 2 of 6

How are your variables arranged?
® Delimited
© Fixed width

- Variables are delimited by a specific character (i.e., comm
- Variables are aligned in fixed width columns.
Are variable names included at the top of your file?
® Yes
Line number that contains variable names: Ei‘
© No

~What is the decimal symbol?
® Period
© Comma

Text file: /Users/jesussalcedo/Desktop/SPSSStatisticsForDummies/Current

O 30 20, 30 B0, 50, O
Name| | age marital address income inccat car carcat ed
21 |ss 1 12 72 3 37 3 1

—— Ir

Cancel || Go Back |Continue| Done

Text Import Wizard - Delimited Step 3 of 6

The first case of data begins on which line number?

&

~How are your cases represented?
@ Each line represents a case

1p

© A specific number of variables represents a case: 22

~How many cases do you want to import?
® All of the cases
OThefirst 1400 cases.

© A random percentage of the cases (approximate): 10 [ %

r Data preview

10 20 30 40 50
e LA e LA L o o s U o] i e o]
Nam age marital address income inccat car carcat ed |=
2| |ss 1 12 72 3 37 3 1
3| |s6 ) 29 153 4 76 3 1
4| js 1 9 28 2 14 1 3
51 j2a 1 4 26 2 13 1 4
6| |25 1 2 23 1 11 1 2 |&
S I— 10
[ Cancel ” Go Back ”f' i ] Done

Also, you can have one line of text represent one case (one row of data in
SPSS), or you can have SPSS count the variables to determine where each row

starts.

And you don't have to read the entire file — you can select a maximum
number of lines to read starting at the beginning of the file, or you can select a
percentage of the total and have lines of text randomly selected throughout
the file. Specifying a limited selection can be useful if you have a large file and

would like to test parts of it.
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8. Click Continue.
0. Specify tab as the delimiter, as shown in Figure 5-4.

SPSS knows how to use commas, spaces, tabs, and semicolons as delimiting
characters. You can even use some other character as a delimiter by selecting
Other and then typing the character into the blank. You can also specify
whether your text is formatted with quotes (which is common) and whether
you use single or double quotes. Strings must be surrounded in quotes if they
contain any of the characters being used as delimiters.

You can specify that a data item is missing in your text file. Simply use two
delimiters in a row, without intervening data.
TIP
@ ® Text Import Wizard - Delimited Step 4 of 6
Which delimiters appear between variables? What is the text qualifi...
[IiTab ] Space @® None
'] Comma | Semicolon © Single quote
[Tl Other: © Double quote
~Leading and Trailing Spaces © Other:
[T Remove leading spaces from string values
"] Remove trailing spaces from string values
Data preview
age marital address |income inccat car carce
55 1 12 72 3 37 3 =
56 0 29 153 4 76 3
28 1 9 28 2 14 1
24 1 4 26 2 13 1
FIGURE 5-4: 25 1 2 23 1 11 1
S ify th 45 0 9 76 4 37 3
pecity the 44 1 17 144 4 72 3
imi 46 1 20 75 4 37 3
delimiters that go i 5 o 2 : . :
between data 29 0 4 19 1 10 - IL
; ; [ —— v
items and which
quotes to use for [ Cancel ][ Go Back ][Continue]
strings.

1 0. Click Continue.

11. Change the variable name and data format (if needed), as shown in
Figure 5-5.

You can change the variable names and specify their types. Here you see that
SPSS has made a guess for the type of each variable. If you did not have
variables names, SPSS would assign the variables the names V1, V2, V3, and so
on. To change a name, select it in the column heading at the bottom of the
window, and then type the new name in the Variable Name field at the top.
You can select the format from the Data Format drop-down list, if you need to
change it.
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@0 Text Import Wizard - Step 5 of 6

Specifications for variable(s) selected in the data preview

Variable name: Original name:
age age

Data format:

|Automatic &

Percentage of values that determine Automatic data format |95

Data preview

|age marital Iaddress income inccat car carca
55 1 112 72 3 37 3 =
|56 0 129 153 4 76 3
28 1 9 28 2 14 1
FIGURE 5-5; 24 1 4 26 2 13 1
25 1 2 23 1 11 1
Name your 45 0 q 76 4 7 IP\'
variables and L e—
select their data Cancel ][ Go Back ][Cuntinue]
types.
This step is optional. If you need to refine your data types, you can do so later
in the Variable View tab of the Data Editor window. The point here is to get the
data into SPSS.
REMEMBER
12. click Continue.
3. In the Would You Like to Save This File Format for Future Use? section,
click No, as shown in Figure 5-6.
Saving the file format for future use is something you would do if you were
loading more files of this same format into SPSS — it reduces the number of
questions to answer and the amount of formatting to do next time.
In the Would You Like to Paste the Syntax? section, you have the chance to
rab a copy of the Syntax language instructions that do all these data manipu-
e grab py of the Syntax language instructions that do all these dat ip
6 lations. But unless you know about the Syntax language (as described in
TECHNICAL Chapters 26 and 27), it's best to pretend that this option doesn't exist for now.
STUFF

14. Click the Done button.

Depending on the type of data conversions and the amount of formatting,
SPSS may take a bit of time to finish. Be patient. The Data View tab of the Data
Editor window will eventually display your data.

15. Look at the data. Correct your data types and formats, if necessary. Then
save it all to a file by choosing File > Save As.

You're instructed to enter a file name. You can just call it Demo. The new file
will have the .sav extension, which indicates that it's a standard SPSS file.

After you complete Step 6 of 6 in the wizard, the data appears in SPSS as shown in
Figure 5-7.
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FIGURE 5-6:
Save the format,
grab the syntax,

or enable
caching.

FIGURE 5-7:
The data
formatted
in SPSS.

® 0 Text Import Wizard - Step 6 of 6

You have successfully defined the format of your...

~Would you like to save this file format for futu... |

= oves | Garnen)

wart w3
1 2 B0 1 @ND
2 ] 280 o
2| w0 Would you like to paste the sy...
4 33 LUl L]
0 5 O Yes

® No

Press the Done button to complete the text imp...

r Data preview

age marital |address |income |inccat car carca
55 1 12 72 3 37 3 =
56 0 29 153 4 76 3

28 1 9 28 2 14 1

24 1 4 26 2 13 1

25 1 2 23 1 11 1

45 0 9 76 4 37 3

44 1 17 144 4 72 3 -
46 1 2n 5 a Z ]

[ Cancel ” Go Back ][L:.-uti“.m“ Done ]

[] [] Untitled$ [DataSetd] - IBM SPSS Statistics Data Editor
File Edit View Data Transform Analyze Graphs Utilities i Window  Help

SHO B« » Bhdl b B3 .40l
Visible: 28 of 28 Variables

‘ S| Gomnnal P ateress F iome Ghiocart| Poar | Ghran | ghed | F emioy G retne | G empen| 39 g rese | G wrless g mutine g voe | g poger | g imemet| G

g 55 i 2 7 3 5 3 1 23 o 3 s o ) 1 f o [
2 56 o 9 153 4 76 3 1| 35 0| 3m 1 1 0 1 1 o »
5 28 1 a 28] 2 14/ 1 3| 3 0| ar a D 0 o 0 0l

. ) 1 4 26 F B[ i 4 o o tm] 3 o 0 o o o

g 3 1 E 1 1 1 1 2 5 o 2m B o 1 o o 1

6 s 0 El 7 4 e 3 3 1 [l 2m 1 i 1 0 o 1

= [ 1 17 184 4 7| 3 2 23 o 3im| 2| i 0 0 o ol

5 8 1 20 7 4 el 3 1 El o 3m 4 o 9 1 o o

5 4 [ 10 6 F 13 1 1 8 o 2m E a 0 [ o Bl

o = o 3 8 1 10 1 B 1) 9 2T 3 0 o g 0 0

i 34 0 0 ) 4 aa 3 3 12 0 2m E 1] 0 1 o 0

2 53| o 17| 7| 3 35| 3| 1| 1 o ar fi ] o 1 o ol

13 28 of 5 El 3| 28 2] 4 [ 0| 1|m 1 o 1 o o al

T 21] 1 El 20/ 1] 10 1 3| o o T | 7 | 0 o o o

15 55 o [ 283 4 7| El 3 1| 0| 2l 1 1 0 o o o

T 35 0 E 0| 3| 35 3 3 9 0| 2m 1 D 1 1 o 1

i [ o 3 = 2 = 7 B 7 0 g 0 0 o o [ o

" 21 o 1 37| 1 18 2| 3 o o 1fm 3 o 1 o o o

1 7 0 o o 7 10 1 1 3] [l g 4 [ 0 o o [

20 2| o a 109 9 54 El 3 20 o 3 1 1 0 o o 1

2 40 1 12] 17| 4 & 3 2 19 0 3t 4 x' 9 1 o o =

1 It
Data View Variable View
IBM SPSS Statistics Processor is ready 4 Unicode:ON

Transferring Data from Another Program

You can get your data into SPSS from a file created by another program, but it isn’t
always easy. SPSS knows how to read some file formats, but if you’re not careful,
you’ll find your data stored in an odd file format. Deciphering some file formats
can be as confusing as Klingon trigonometry. SPSS can read only from file formats
it knows.
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SPSS recognizes the file formats of several applications. Here’s a complete list:

3 IBM SPSS Statistics (.sav): IBM SPSS Statistics data, and also the format used
by the DOS program SPSS/PC+

¥ dBase (.dbf): An interactive database system

¥ Text (.txt, .csv, .dat, and .tab): A standard text file that contains unformat-
ted text

¥ CSV (.csv): A plain text file that contains a list of data

3 Microsoft Excel (.xls, .xIsx, .xIsm): A spreadsheet for performing calculations
on numbers in a grid

3 Portable (.por): A portable format read and written by other versions of SPSS,
including other operating systems

¥ Lotus (.w): A spreadsheet for performing calculations with numbers in a grid

¥ SAS (.sas7bdat, .sd7, .sd2, .ssd01, ssd04, and .xpt): Statistical analysis
software

¥ Stata (.dta): Statistical analysis and graphics software

¥ Sylk (.slk): A symbolic link file format for transporting data from one applica-
tion to another

¥ Systat (.syd and .sys): Software that produces statistical and graphical results
3 Database: Any database with an ODBC connection
3 Cognos TM1: A budgeting and forecasting program

3 Cognos Business Intelligence: A web-based reporting tool

Although SPSS knows how to read any of these formats, you may still need to
make a decision from time to time about how SPSS should import your dataset.
But you have some advantages:

¥ You know exactly what you want — the form of data appearing in SPSS is
simple, and what you see is what you get.

¥ SPSS has some reasonable defaults and makes some good guesses along
the way.

¥ You can always fiddle with things after you've loaded the data.
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REMEMBER

FIGURE 5-8:
Select which
data in the
spreadsheet
to include.

You're only reading from the data file, so you can’t hurt it. Besides, you have
everything safely backed up, don’t you? If the process gets hopelessly balled up,
you can always call it quits and start over. That’s the way we do it — we think of
it as a learning process.

Reading an Excel file

SPSS knows how to read Excel files directly. If you want to read data from an Excel
file, we suggest you read the steps in “Reading Simple Data from a Text File,”
earlier in this chapter, because the two processes are similar. If you understand
the decisions you have to make in reading a text file, reading from an Excel file
will be duck soup.

Do the following to read this data into SPSS:

1. chooseFile = Import Data > Excel.

2. Select the demo.xls file and then click Open.
The file is in the SPSS installation directory.

3. Select the data to include.

An Excel file can contain more than one worksheet, and you can choose the
one you want from the drop-down list, as shown in Figure 5-8.

[ JeN ] Read Excel File

/Users/jesussalcedo/Desktop/SPSSStatisticsForDummies/Current Version 23 Demo Data/demo.xls

Worksheet: ". 6401] -

Range:

¥ Read variable names from first row of data

¥ Percentage of values that determine data type: 95
|

[ Remove leading spaces from string values

Remove trailing spaces from string values

Preview
& Age | & Marit... & Addr... ¢ Income ¢ Inco...| ¢ Carpr... & Carpr... & Educ

1 55 1 12 72 13 37 3 1 [<]
2 56 0 29 153 4 76 3 1 .
] 28 1 9 28 2 14 1 3

4 24 1 4 26 2 13 11 4

B 25 1 2 23 1 11 1 2

6 45 0 9 76 4 37 3 3 L
7: 44 1 17 144 4 72 2 T ‘l

® Final data type is based on all data and can be different from the preview, which is based on
the first 200 data rows. The preview displays only the first 500 columns.
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TIP

©

REMEMBER

o
T
TECHNICAL
STUFF

Also, if you've elected to read only part of the data, enter the Excel cell num-
bers of the upper-left and lower-right corners here. You can specify if the
names of variables appear in the first row and what percentage of data to use
to determine the variable type. Finally you can remove any leading or trailing
spaces.

It's a good idea to inspect the data preview to make sure the variables and data
are read properly.

4. click OK.
Your data appears in the SPSS window.

5. Switch to the Variable View tab to examine the variable definitions and
make any changes.

SPSS makes a bunch of assumptions about your data, and some of those
assumptions are probably wrong.

6. save the file using your chosen SPSS name, and you're off and running.

Reading from an unknown program type

SPSS can import most file types, but there are exceptions. However, almost any
file format in current use can be exported as a text file and then imported into
SPSS.

SPSS has been around for more than a half century, and organizations, such as the
IRS, have hundreds of millions of rows of SPSS data. Very large files or older data-
sets are almost always stored as text files. So if you’re going to be an SPSS power
user, you’ll need to get comfortable with text files.

If your data is in an application that can’t directly create a file of a type that SPSS
can read, getting the data into SPSS may be easier than you think. If you can get
the information out of your application and into a text file, it’s fairly easy to have
SPSS read the text file.

Years ago, it was not uncommon that an unusual proprietary format could not be
exported to a text format but could be easily imported into SPSS. Although this
situation is now rare, expert users of SPSS syntax can import even the most arcane
data formats.

The data file you output to SPSS doesn’t have to include the variable names, just
the values that go into the variables. You can format the data in the file by using
spaces, tabs, commas, or semicolons to separate data items. Such dividers are
known as delimiters. Another method of formatting data avoids delimiters. In that
method, you don’t have to separate the individual data items, but you must make
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REMEMBER

TIP

each data item a specific length, because you have to tell SPSS exactly how long
each item is.

The most intuitive format is to have one case (one row of data) per line of text.
That way, the data items in your text file are in the same positions they’ll be in
when they’re read into SPSS. Alternatively, you can have all your data formatted
as one long stream, but you’ll have to tell SPSS how many items go into each case.

Always save this kind of raw data as simple text; the file you store it in should have
the .txt extension so SPSS can recognize it for what it is.

An even more roundabout way to bring in data from another application is by
selecting, copying, and pasting the data you want, but we don’t recommend doing
this method. The places you’re copying from and pasting to are usually larger
than the screen, so highlighting and selecting can be tricky. You must be ready to
choose Edit == Undo when necessary.

A better method is to write the data to a file in a format understood by SPSS, and
then read that file into SPSS. SPSS knows how to read some file formats directly.
Using such a file as an intermediary means you’ll have an extra backup copy of
your data, and that’s never a bad idea.

When you drag a data file to the SPSS Data Editor window, SPSS chooses the
appropriate format and begins reading the data file.

Saving Data

TIP

Writing data from SPSS is easier than reading data into SPSS. All you do is choose
File = Save As, select your file type, and then enter a file name.

You have lots of file types to choose from. You can write your data not only in
3 plain-text formats, but also in 3 Excel spreadsheet formats, 3 Lotus formats,
3 dBase formats, 9 SAS formats, 1 SYLK format, 1 Portable format, and 18 Stata
formats.

If you’ll be exporting data from SPSS into another application, find out what kinds

of files the other application can read, and then use SPSS to write in one of those
formats.
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