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Chapter 13
Building Graphs Using
Chart Builder

TIP

n this chapter, you discover how to create all the different graph types by

following simple, step-by step procedures. Although we don’t cover every

combination of chart features, you can use the steps here to produce some neat
graphs. When you get the basic idea of how to build graphs using Chart Builder,
you can explore making some graphs on your own.

The first part of the chapter provides examples of simple graphs and charts and
shows you how to build the graphs that you’re already familiar with. Next, you see
examples of graph types that may be less familiar and are more complex. The last
part of the chapter focuses on creating maps.

You can work through the examples to get an overview of building graphs using
SPSS — not a bad idea for a beginner — or simply choose the look you want for
your data and follow the steps here to construct the chart that does the job. Either
way, when you get a handle on the basics, you can step through the process again
and again, using your data and trying variations until you get charts that appear
the way you want them to.

When you use Chart Builder, you can drag and drop any variables you want to see

into your graph. If the variable doesn’t make sense there, the drop will fail. Chart
Builder in SPSS will tell you what will and won’t work.
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@ No matter what you try to do while building a graph, your data won’t change.

REMEMBER

Simple Graphs

184

The graphs in this section are a great way to use Chart Builder to show the distri-
bution of a single variable or to display relationships between two variables. We
cover the following types of graphs: scatterplot, dot plot, bar graph, error bar,
histogram, population pyramid, and stacked area chart.

Simple scatterplots

A scatterplot is simply an xy plot where you don’t care about interpolating the
values — that is, the points aren’t joined with lines. Instead, a disconnected dot
appears for each data point. The overall pattern of these scattered dots often
exposes a pattern or trend.

Follow these steps to construct a simple scatterplot:

1. chooseFile > Open > Data and open the Cars.sav file.

The file is not in the SPSS installation directory. You have to download it from
the book’s companion website at www . dummies . com/go/spss4e.

. Choose Graphs > Chart Builder.

In the Choose From list, select Scatter/Dot.

A WN

. Select the first scatterplot diagram (the one with the Simple Scatter
tooltip), and drag it to the panel at the top.

o

In the Variables list, select Horsepower and drag it to the rectangle
labeled X-Axis in the diagram.

In a scatterplot, both the x-axis and y-axis variables are scale. Look for the ruler
icon when dragging your variable over.

REMEMBER 6 In the Variables list, select Miles Per Gallon (MPG) and drag it to the
rectangle labeled Y-Axis in the diagram.

7. Cclick OK.

The chartin Figure 13-1 appears, where each dot in the scatterplot represents
both the horsepower and miles per gallon for each car. As you can see, miles
per gallon depends largely on horsepower. The pattern of the dots clearly
shows a linear trend from the upper left to the lower right. The relationship
between horsepower and miles per gallon is inverse: As the horsepower of a
car increases, there is a decrease in the miles per gallon that the car gets.
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FIGURE 13-1:

A simple
scatterplot
showing the
effect of
horsepower on
miles per gallon.

Simple Scatter of Miles per Gallon by Horsepower
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Simple dot plots

No plot is simpler to produce than the dot plot. It has only one dimension. Although
SPSS groups it among the scatterplots, it displays data more like a bar chart. As
you build this type of chart, you’ll notice that you won’t need a y-axis.

It’s easy to create a dot plot. You select the dot plot as the type of graph you want
and then select one variable. SPSS does the rest. The following steps guide you
through the process of creating a simple dot plot:

1. chooseFile > Open > Data and open the Employee data.sav file.

The file is in the SPSS installation directory.

Choose Graphs > Chart Builder.

In the Choose From list, select Scatter/Dot.

»WN

Select the seventh graph image (the one with the Simple Dot Plot tooltip)
and drag it to the panel at the top.

o

In the Variables list, select Date of Birth and drag it to the X-Axis
rectangle.

6. Click OK.

The chart shown in Figure 13-2 appears, displaying the number of people born
each year. As you can see, more people were born between 1960 and 1970
than any other time periods.
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FIGURE 13-2:
A dot plot
showing the

relative number
of people born
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each year.

Simple Dot Plot of Date of Birth
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Simple bar graphs

A bar graph is a comparison of relative magnitudes. Simple bar graphs and simple
line graphs are the most common ways of charting statistics. It would make an
interesting statistical study to determine which is more common. The results
could be displayed as either a bar graph or a line graph, whichever is more popular.

A fundamental bar graph is simple enough that the decisions you need to make
when preparing one are almost intuitive. Follow these steps to generate a simple

bar graph:

1. selectFile > Open > Data and open the Employee data.sav file.
The file is in the SPSS installation directory.

2. Choose Graphs = Chart Builder.

3. In the Choose From list, select Bar.

4. select the first graph image (the one with the Simple Bar tooltip) and
drag it to the panel at the top of the window.

5. Inthe Variables list, select Employment Category and drag it to the X-Axis
rectangle.

6. Inthe Variables list, select Current Salary and drag it to the Count

rectangle.

The label changes from Y-Axis to Mean to indicate the type of variable that will
now be applied to that axis.
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FIGURE 13-3:
A simple bar
graph.

TIP

7. Cclick OK.

The simple bar graph in Figure 13-3 appears. You can see that the average
current salary for the manager employment category is much higher than the
average current salary for the clerical and custodial employment categories.

Simple Bar Mean of Current Salary by Employment Category

360,000

$40,000

Mean Current Salary

520,000

Clerical Custodial Manager

Employment Category

The display of data in a line chart and a bar chart is similar. If you decide to display
data as a bar chart, you should probably try the same data as a line graph to see
which you prefer.

Simple error bars

Some errors come from flat-out mistakes — but those aren’t the errors we’re
talking about when we describe error bars. Statistical sampling can help you arrive
at a conclusion, but that conclusion has a margin of error. This margin can be cal-
culated and quantified according to the size of the sample and the distribution of
the data. For example, suppose you want to know how typical a result is when you
calculate the mean of all values for a particular variable — for any one case, the
mean could be as big as the largest value or as small as the smallest value. The
maximum and minimum are the extremes of the possible error. You can choose
values and mark the points that contain, say, 90 percent of all values. Marking
these points on a graph creates error bars.

You can add error bars to the display of most types of graphs. For example, you

could add error bars to the simple bar graph presented earlier (refer to Figure 13-3)
by making selections in the Element Properties dialog.
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A bar chart with
error bars that
show a range
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For an example of how to add error bars to a bar chart, follow the same procedure
described previously in the “Simple bar graphs” section — but just before the
final step (clicking OK to produce the chart), do the following:

1.
2.
3.

In the Element Properties window, make sure that a check mark appears
in the Display Error Bars option and that Bar1 is selected.

Select Display Error Bars and make sure the Confidence Intervals value is
95% (the default).

Click OK.

The chart shown in Figure 13-4 appears.

Mean Current Salary

FIGURE 13-4:

containing
95 percent
of all values.

Simple Bar Mean of Current Salary by Employment Category

360,000

$40,000

520,000

30

Clerical Custodial Manager

Employment Category

Error Bars: 95% ClI

Another way to present the same data is to display the range of errors without
displaying the full range of all values. To do so, follow these steps:

1.

i AWN

Choose File > Open > Data and open the Employee data.sav file.
The file is in the SPSS installation directory.

Choose Graphs > Chart Builder.

In the Choose From list, select Bar.

Select the seventh graph image (the one with the Simple Error Bar
tooltip) and drag it to the panel at the top of the window.

In the Element Properties window, make sure the Point1 and Display Error
Bars options are selected and that Confidence Intervals Level is set to 95%.
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6. Inthe Variables list, select Employment Category and drag it to the X-Axis
rectangle.

7. Inthe Variables list, select Current Salary and drag it to the Mean
rectangle.

The label changes from Y-Axis to Mean to indicate the type of data that will be
displayed on that axis.

8. Cclick OK.

The bar graph in Figure 13-5 appears.

Simple Error Bar Mean of Current Salary by Employment Category

360,000 :*:

$40,000

Mean Current Salary

FIGURE 13-5: 520,000

An error bar
graph showing
the mean values
opper ang Clerical Custodial Manager

the upper and
lower bounds
of the error.

Employment Category

Error Bars: 95% ClI

This example shows one way to make error calculations: The magnitude of the
error is based on 95 percent of all values being within the upper and lower error
bounds. If you prefer, you can base the error on the bell curve and mark the upper
and lower errors at some multiple of the standard error or standard deviation.

Simple histograms

A histogram represents the number of items that appear within a range of values.
You can use a histogram to look at a graphic representation of the frequency
distribution of a variable’s values. Histograms are useful for demonstrating the
patterns in your data when you want to display information to others rather than
discover data patterns for yourself.

CHAPTER 13 Building Graphs Using Chart Builder 189



You can use the following steps to create a simple histogram that displays the
frequency of the ages at which the respondent’s first child was born:
1. chooseFile > Open > Data and open the GSS2012 Abbreviated.sav file.

The file is not in the SPSS Statistics installation directory. Download it at
www . dummies.com/go/spssée.

N

Choose Graphs => Chart Builder.
The Chart Builder dialog appears.

. Inthe Choose From list, select Histogram.

panel at the top of the window.

In the Variables list, select the R'S AGE WHEN 1ST CHILD BORN variable
and drag to the X-Axis rectangle in the panel.

3
4, Drag the first graph diagram (with the Simple Histogram tooltip) to the
5
6

Click OK.

The histogram shown in Figure 13-6 appears. (Although the graph looks like a
bar chart, it's a histogram.) The majority of respondents had their first child
when they were in their late teens through mid-twenties.

Simple Histogram of R'S AGE WHEN 1ST CHILD BORN
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FIGURE 13-6:
A histogram
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age at which the 00
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190  PART 4 Graphing Data


https://www.dummies.com/go/spss4e

FIGURE 13-7:

A population
pyramid shows
the occurrence of
values within
categories.

Population pyramids

A population pyramid provides an immediate comparison of the number of items
that fall into different categories. It’s called a pyramid because it often takes a tri-
angular shape — wide at the bottom and tapering to a point at the top.

Follow these steps to build a pyramid histogram chart:

1. chooseFile > Open > Data and open the GSS2012 Abbreviated.sav file.

Download the file at www . dummies.com/go/spssde.

Choose Graphs => Chart Builder.

In the Choose From list, select Histogram.

Drag the fourth graph diagram (with the Population Pyramid tooltip) to
the panel at the top of the window.

i AWN

In the Variables list, do the following:

a. Select the Respondent’s Sex variable and drag it to the Split Variable rectangle.
This variable a categorical variable with two possible values, so one category
will be placed on each side of the center line.

b. Select R'S AGE WHEN 1ST CHILD BORN and drag it to the Distribution Variable
rectangle.

6. Cclick OK.

The chart shown in Figure 13-7 appears. You can see that males tended to be
slightly older than females when they had their first child.

Population Pyramid Frequency R'S AGE WHEN 1ST CHILD BORN by
RESPONDENTS SEX

RESPONDENTS SEX
FEMALE MALE

60 60
50 50
40 40
30

30

20 20

R'S AGE WHEN 1ST CHILD BORN
NYO8 ATIHD LST NIHM 3DV S)d

80.0 60.0 40.0 20.0 0.0 200 40.0 60.0 80.0

CHAPTER 13 Building Graphs Using Chart Builder 191


https://www.dummies.com/go/spss4e

192

©

REMEMBER

TIP

You can create pyramid histograms based on categorical variables with three, four,
or more values. The plot produced will consist of as many pairs as needed (and
even a single-sided pyramid for one category, if necessary) to display bars that
show the relative number of occurrences of different values in the categories.

Stacked area charts

An area graph is really a line graph, or a collection of line graphs, with the areas
below the lines filled in to represent the mean of one or more values at the various
points.

In a stacked area chart, more than one variable is displayed along the x-axis. The
values are stacked in such a way that the ups and downs of the lower value in the
chart affect the upper values in the chart. That is, the chart is not a group of
independent lines; instead, it represents a cumulative total — to which each
variable displayed adds a value.

To include two or more variables in your chart, simply repeat Step 5c in the
following procedure. They will all appear in the legend at the upper right, and
each variable will provide the value for one layer of the stack.

If you include more than one variable, make sure that the variables you select for
stacking have similar ranges of values so that the scale on the left will make sense
for all of them. If, for example, one variable ranges in the thousands and the other
doesn’t go over a hundred, the smaller one will compress itself visually and appear
in the final graph as a line.

When you select multiple variables for stacking, be sure to select them in the order
in which you want them stacked. The first one you select remains on top, the
second one is placed under it, and so on.

The two types of area charts — simple and stacked — act the same when you con-
struct them. You can select the stacked chart and produce a simple area chart, or
you can start with the simple area chart and stack your variables.

Follow these steps to produce a stacked area chart with two stacked variables:

1. chooseFile > Open > Data and open the Employee data.sav file.
The file is in the SPSS installation directory.
2. Cchoose Graphs = Chart Builder.
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3. In the Choose From list, select Area.

4, Drag the second graph diagram (with the Stacked Area tooltip) to the
panel at the top of the window.

5. Inthe Variables list, do the following:

a. Select the Educational Level variable, right-click it and change its measurement
level to Nominal, and then drag it to the X-Axis rectangle.

b. Select Current Salary and drag it to the Y-Axis rectangle (now renamed Count).

¢. Select Beginning Salary and drag it to the Current Salary rectangle. A plus sign
appears when you drag Beginning Salary over Current Salary. Be sure to
drag Beginning Salary to the plus sign and not simply to the rectangle in
general. (The plus sign appears at the top of the rectangle when you drag
the new variable’s name across it.)

The Create Summary Group dialog appears. After dragging in Beginning Salary,
the Stacked: Set Color rectangle is relabeled Index.

6. Cclick OK.

The area chart shown in Figure 13-8 appears. Employees with at least a
bachelor's degree (16 or more years of education) had a higher initial salary
and their current salary increased at a much faster rate.

Stacked Area Mean of Current Salary, Mean of Beginning Salary by
Educational Level (years)...

M Current Salary
M Beginning Salary
$120,000

$100,000

$80,000

Mean

$60,000

540,000

FIGURE 13-8: $20,000

A stacked area
chart showing

one variable 778 12 14 15 16 17 18 19 20 21

added to another

in the display.

Educational Level (years)
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Fancy Graphs

194

Fancy graphs are just like they sound: fancy. Whether you’re trying to show
relationships with lines, bars, dots, or more, you can use Chart Builder to create
these graphs to show relationships between more than two variables.

Charts with multiple lines

A line chart works well as a visual summary of categorical values. They’re useful
also for displaying timelines because they demonstrate up and down trends
so well. Line graphs are popular because they’re easy to read. If they’re not the
most common type of statistical chart, they’re a contender for the title.

You can have more than one line appear on a chart by adding more than one
variable name to an axis. But the variables must contain a similar range of values
so they can be properly represented by the same axis. For example, if one variable
ranges from 0 to 1,000 pounds and another variable ranges from 1 to 2 pounds, the
values of the second variable will show up as a straight line, regardless of how
much the values fluctuate.

The following steps generate a basic multiline graph:

1. chooseFile > Open > Data and open the Cars.sav file.
Download the file at www . dummies . com/go/spss4e.
2. Choose Graphs = Chart Builder.

3. Inthe Choose From list, select Line to specify the general type of graph to
be constructed.

4. To specify that this graph should contain multiple lines, select the second
diagram (with the Multiple Line tooltip) and drag it to the panel at
the top.

5. In the Variables list, right-click Model Year and select Ordinal. Then select
Model Year and drag it to the X-Axis rectangle in the diagram.

6. Inthe Variables list, select Engine Displacement and drag it to the Y-Axis
rectangle in the panel at the top where it says Count.

The word Mean is added to the annotation because the values displayed on
this axis will be the mean values of the engine displacement.

7. Inthe Variables list, select Country of Origin and drag it to the Set Color
rectangle in the panel at the top.
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FIGURE 13-9:
Aline graph
charting Engine
Displacement
against Model
Year according to
Country of Origin.

8. Cclick OK.

The chart shown in Figure 13-9 appears. The mean engine displacement for
European and Japanese cars is similar across the years, whereas the values for
American cars are different, especially in earlier years.

Multiple Line Mean of Engine Displacement (cube inches) by Model Year
(modulo 100) by Country of Origin
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The following steps generate a multiline graph with two variables in the Y-axis:

1. chooseFile > Open > Data and open the Cars.sav file.
You can download the file at www . dummies.com/go/spss4e.
2. Choose Graphs > Chart Builder.

3. Inthe Choose From list, select Line to specify the general type of graph to
be constructed.

4. 1o specify that this graph should contain multiple lines, select the second
diagram (with the Multiple Line tooltip) and drag it to the panel at
the top.

5. Inthe Vvariables list, right-click Model Year and select Ordinal. Then select
Model Year and drag it to the rectangle named X-Axis in the diagram.

6. Inthe Variables list, select Engine Displacement and drag it to the Y-Axis
rectangle in the panel at the top where it says Count.

The word Mean is added to the annotation because the values displayed on
this axis will be the mean values of the engine displacement.
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FIGURE 13-10:

Adding another

196

variable to
the y-axis.

7. Inthe Variables list, select Horsepower and drag it to the Y-axis rectangle
in the panel at the top.

Be careful how you drop Horsepower. To add Horsepower as a new variable,
you want to drop it on the little box containing the plus sign, as shown in
Figure 13-10. If you drop the new name on top of the one that's already there,
the original variable could be replaced.

@ @ Create Summary Group

The values from your variables will be used to
summarize your data. The names of each variable
will be used as categories in the chart
m H Values are represented by a special SUMMARY
variable assigned to the Y axis. Variables that
INDEX define categories are represented by a special
INDEX variable, which can be used on a

categorical axis or as a grouping or paneling
variable.

>
e |
=
=
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>
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INDEX Category Labels:
Engine Displacement (cube inches)
Horsepower

8. When the Create Summary Group window appears, telling you that SPSS
is combining the two variables along the y-axis, click OK.

9. click oK.

The chart shown in Figure 13-11 appears.

The variables you choose as members of the y-axis must have a similar range of
values to make sense. For example, if you were to choose Vehicle Weight and
Engine Displacement to be charted together, the result wouldn’t be all that
interesting; the Vehicle Weight values would be in the thousands and the Engine
displacement, regardless of their variation, would all appear in a single line at the
bottom. In Chapter 24, we discuss how to edit these graphs to display information
in a better way.

Colored scatterplots

Colored scatterplots can be dramatic in appearance, but clarity is not their strongest
point. Because the scatterplot is drawn on a two-dimensional surface, you may
find it difficult to envision where each point is supposed to appear in space. On the
other hand, if your data distributes appropriately on the display, the resulting
chart may demonstrate the concept you’re trying to get across.
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FIGURE 13-11:

A line graph with
two variables in
the y-axis.

TIP
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The following example uses the same data as in the preceding example but dis-
plays it as a three-dimensional plot:

1.

i AWN

Choose File > Open > Data and open the Cars.sav file.
Download the file at www . dummies.com/go/spssde.
Choose Graphs => Chart Builder.

In the Choose From list, select Scatter/Dot.

Select the third scatterplot diagram (with the Grouped Scatter tooltip)
and drag it to the panel at the top.

In the Variables list, do the following:

a. Select Engine Displacement and drag it to the X-Axis rectangle.
b. Select Miles Per Gallon and drag it to the Y-Axis rectangle.

¢. Select Country of Origin and drag it to the Set Color rectangle.
Click OK.

The graph shown in Figure 13-12 appears. In general, you can see that there is
an inverse relationship between horsepower and miles per gallon: As the
horsepower of a car increases, its miles per gallon decreases. Also, note how
many of the Japanese and European cars are in the same area of the graph,
whereas American cars tend to have much larger engine displacement values,
which correspond to fewer miles per gallon.

We recommend using a bubble chart rather than a 3D scatterplot when
displaying three-scale variables because graphs are often not printed in color.
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GURE 13-12:
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Scatterplot matrices

A scatterplot matrix is a group of scatterplots combined into a single graphic image.
You choose a number of scale variables and include them as a member of your
matrix, and SPSS creates a scatterplot for each possible pair of variables. You can
make the matrix as large as you like — its size is controlled by the number of
variables you include.

The following steps walk you through the creation of a matrix:

1.

»WN

(5

Choose File > Open=>Data and open the Cars.sav file.
You can download the file at www . dummies . com/go/spss4e.
Choose Graphs => Chart Builder.

In the Choose From list, select Scatter/Dot.

Select the eighth graph image (with the Scatterplot Matrix tooltip) and
drag it to the panel at the top.

In the Variables list, drag Engine Displacement to the Scattermatrix
rectangle in the panel.

The selected name replaces the label in the rectangle.

Drag the variable names Miles Per Gallon, Horsepower, and Vehicle
Weight to the plus sign on the x-axis.

The labels may or may not change with each variable you add, depending on
their length and the amount of space available. All your labels appear in the list
at the bottom of the Element Properties dialog.
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FIGURE 13-13:
A four-by-four
matrix of
scatterplots.

7. Cclick OK.

The chartin Figure 13-13 appears. Each variable is plotted against each of the
others. Note that the scatterplots along the diagonal from the upper left to the
lower right are blank —because it's useless to plot a variable against itself.
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Stacked bar charts

A stacked bar chart is similar to the clustered bar chart in that it displays multiple
values of a variable for each value of a categorical variable. But the stacked bar
chart does so by stacking them instead of placing them side by side. The following
chart displays the same data as the preceding example, but it emphasizes differ-
ent aspects of the data.

Follow these steps to create a stacked bar chart:

1. chooseFile > Open > Data and open the Cars.sav file.

Download the file from this book’s companion website at www . dummies . com/
go/spssée.

N

Choose Graphs > Chart Builder.

W

In the Choose From list, select Bar.

4. select the third graph image (with the Stacked Bar tooltip) and drag it to
the panel at the top of the window.
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FIGURE 13-14:

A bar graph with
values displayed
in stacks.

5. Inthe Variables list, do the following:
a. Right-click Model Year and select Ordinal.
b. Drag Model Year to the X-Axis rectangle.

¢. Drag Miles Per Gallon to the Count rectangle. The rectangle was originally
labeled Y-Axis. The label changed to help you understand the type of
variable that needs to be placed there.

d. Drag Country of Origin to the rectangle in the upper-right corner, the one now
labeled Stack Set Color.

6. Cclick OK.

The graph in Figure 13-14 appears.

Stacked Bar Mean of Miles per Gallon by Model Year (modulo 100) by
Country of Origin
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Pie charts

Pie charts are the easiest graphs to spot — they’re the only chart that shows up as
a circle. The purpose of a pie chart is simply to show how something (the “whole”)
is divided into pieces — whether two, ten, or any other number. Each slice in the
pie chart represents its percentage of the whole. For example, if a slice takes up
40 percent of the total pie, that slice represents 40 percent of the total number.
A pie chart is also called a polar chart, so SPSS calls this option Pie/Polar.
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FIGURE 13-15:

A pie chart
displaying the
number of
employees in
each employment
category.

In the following steps, you construct a pie chart:

1. chooseFile > Open > Data and open the Bank.sav file.
Download the file at www . dummies . com/go/spss4e.

Choose Graphs => Chart Builder.

In the Choose From list, select Pie/Polar.

Drag the pie diagram to the panel at the top of the window.

uuhWwWN

Click the Groups/Point ID tab, and then click the Columns Panel variable.

A rectangle with Panel should appear in the summary area.

Click the Options tab, and then select Wrap Panels at the bottom.

In the Variables list, drag Sex of Employee to the Slice By rectangle at the
bottom of the panel.

In the Variables list, drag Employment Category to the Panel rectangle at
the top of the panel.

O 0 NO

Click OK.

The pie chart shown in Figure 13-15 appears, displaying the gender breakdown
for each employment category.

Pie Chart Count of Sex of employee by Employment category

Clerical Office trainee Security officer Sex of
employee
W Males
M Females
College trainee Exempt employee MBA trainee
Technical
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Clustered range bar graphs

The clustered range bar graph displays the relationship among five variables. No
other chart can be used to so clearly display so many variables. This example
demonstrates the relationships among five employee variables: years of employ-
ment, income ranges, years with employer, ages, and the years they’ve lived at
their current addresses.

Do the following to build a clustered range bar graph:

1. chooseFile > Open > Data and open the Customer_dbase.sav file.
The file is in the SPSS installation directory.
. Choose Graphs > Chart Builder.

In the Choose From list, select High-Low.

A WN

. Drag the third graph diagram (with the Clustered Range Bar tooltip) to
the panel at the top of the window.

o

In the Variables list, do the following:

a. Drag the Years With Current Employer [empcat] variable to the Cluster on X
rectangle in the upper-right corner.

b. Drag the Income Category in Thousands [inccat] variable to the X-Axis rectangle
at bottom.

¢. Dragthe Age In Years [oge] variable to the High Variable rectangle at the top left.

d. Right-click Years with Current Employer [employ] and make it Scale. Then drag
the measure Years with Current Employer [employ] variable to the Low Variable
rectangle at the center left.

e. Right-click Years at Current Address [address] and make it Scale. Then drag the
Years at Current Address [address] variable to the Close Variable rectangle at the
bottom left.

6. Click OK.

The high-low graph shown in Figure 13-16 appears.

Differenced area graphs

A differenced area graph provides a pair of line graphs that emphasize the differ-
ence between two variables, filling the area between them with a solid color. The
two graphs are plotted against the points of a categorical variable.
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FIGURE 13-16:

A clustered range
bar graph,
displaying
relationships
among five
variables.
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following steps produce a differenced area graph:

Choose File > Open>Data and open the property_assess.sav file.
The file is in the SPSS installation directory.

Choose Graphs > Chart Builder.

In the Choose From list, select High-Low.

Drag the fourth graph diagram (with the Differenced Area tooltip) to the
panel at the top of the window.

In the Variables list, do the following:

a. Drag the Township variable to the X-Axis rectangle.

b. Drag the Sale Value of House variable to either Y-Axis rectangle.

¢. Drag the Value at Last Appraisal variable to the other Y-Axis rectangle.

Note that the color of the differenced area of the graph may be blue instead of
red, depending on which variable is placed in which Y-Axis rectangle.

Click OK.

The differenced area chart shown in Figure 13-17 appears. You can see the
difference between the mean values for the sale and appraisal of homes
broken down by region. In each region, the sale value was larger than the
appraisal value, which is why the differenced area appears in the color
associated with the larger value (red).
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FIGURE 13-17: 50.00
In a differenced
area chart, the

Differenced Area Mean of Value at last appraisal,Mean of Sale value of
house by Township
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Dual-axis graph

204

Many types of graphs allow you to plot two or more variables on the same chart,
but they must always be plotted against the same scale. In the dual-axis graph, two
variables are plotted and two different scales are used to plot them. As a result, the
values don’t require the same ranges (as they do in the other plots). The curves
and trends of the two variables can be easily compared, even though they’re on
different scales.

Two variables with different ranges that vary across the same set of categories can
be plotted together, as shown in the following example:
1. chooseFile > Open > Data and open the property_assess.sav file.
The file is in the SPSS installation directory.
2. Choose Graphs = Chart Builder.
3. In the Choose From list, select Dual Axes.

4, Drag the first diagram (the Dual Y Axes with Categorical X Axis tooltip) to
the panel at the top of the window.

PART 4 Graphing Data



FIGURE 13-18:

A dual-axis graph
displaying the
curves inscribed
by two variables
with different
ranges.

5. Inthe Variables list, do the following:

a. Drag the Value at Last Appraisal variable to the Y-Axis rectangle on the left.

b. Drag the Sale Value of House variable to the Y-Axis rectangle on the right, which

is now named Count.

¢. Drag the Township variable to the X-Axis rectangle.

6. Cclick OK.

The dual-axis graph shown in Figure 13-18 appears.
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Fancy Maps Using Graphboard
Template Chooser

In this section, we describe fancy maps that you can create only with Graphboard
Template Chooser. When data has a geographical component, maps allow you to
see patterns in the data that might not be evident in traditional charts, such as

clusters or regions with a higher concentration of values.

The three types of maps we describe are the heat map, the choropleth of values

map, and the coordinates on a reference map.
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Heat map

A heat map calculates a summary statistic for a continuous field for the joint dis-
tribution of two categorical fields. A heat map is like a table that uses colors
instead of numbers to represent cell values. Furthermore, color saturation is used
to represent values that correspond to the variables depicted on the map (here,
darker values represent higher values). Bright deep red indicates the highest
value, and gray indicates a low value. The value of each cell, in this instance, will
be the mean of Current Salary by Gender and Employment Category.

The following steps generate a heat map:

1. chooseFile > Open > Data and load the Bank.sav file.

Download the file from the book’s companion website at www . dummies . com/
go/spssée.

. Choose Graphs > Graphboard Template Chooser.

Make sure the Basic tab is selected.

A WN

. Using Ctrl-click, select Sex of Employee, Employment Category, and
Current Salary.

o

Select Heat Map as the graph type.

o

Click OK.

The heat map shown in Figure 13-19 appears. Employee current salary is
broken down by gender and employment category. You can see that males
have a higher salary than females across all employment categories. Likewise,
differences exist among employment categories. For example, males employ-
ees in the technical category have the highest current salary, while female
employees in the technical and security categories have the lowest salary
(because there are no people with this combination).

Choropleth of values

Maps can be used in a wide variety of settings to help answer many important ques-
tions. For example, organizations may want to know the location of certain client
characteristics to determine where to send salespeople, where to hire additional
employees, where to create new stores, or which marketing campaigns to use.

Investigators can also use maps to determine the spread of disease, fluctuations in
temperature, population growth, distance traveled, where to send school buses, or
how to create new districts. One of the nice features of maps is that they give
meaningful context and can allow you to see patterns in data that might not be
evident in traditional charts.
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FIGURE 13-19:

A heat map
charting current
salary against
gender and
employment.
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Maps can be created from a single variable or multiple variables. Maps can use
categorical variables, continuous variables, and combinations of categorical and
continuous variables.

The choropleth of values map shows relationships between two categorical variables
and the mode for each location is depicted on the map in a different color.

Let’s go through some examples on how to create maps:

1. choose File > Open > Data and load the Worldsales.sav file.

Download the file at www . dummies.com/go/spss4e.

N

Choose Graphs > Graphboard Template Chooser.

3. Make sure the Basic tab is selected. Then select Continent, hold down the
Ctrl key, and click Product Variable.

When you selected Continent, you could create only one type of map. When
you then selected Product Variable, you selected a second categorical variable
and can now create six types of maps.

4. select Choropleth of Values as the graph type.

L

Click the Detailed tab.

The Detailed tab is an alternative to the Basic tab where you can specify all
required variables, summary statistics, and aesthetics. You select the graph
type, specify the type of data, and then specify details that are not available
on the Basic tab.
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The Detailed tab is optional for most visualizations but is required when you're
creating a map. You need to make sure that the right template and data key
are selected. For example, if you have data for Africa, the map template must

also be for Africa.

6. click the Select a Map File button.

The Select a Map dialog appears so you can select the appropriate map key

and data key.

7. click the Map drop-down list and select Continents.

The map key consists of the values represented on the map template, which is

basically the areas represented on the map.

8. click the Data Key drop-down list and select Continent.

A data key is a variable that contains the values in your dataset. It ties the data
to the map, so that the data can be displayed on the map correctly. It's
important to make sure that the map and data key values match.

9. click the Compare button.

The screen shown in Figure 13-20 appears. Now you can see which keys in the
map key and data key match. Ideally, you want all the values to match. Make
sure that all values for the data key match the values on the map. It's okay if
your data does not have some of the values on the map key.

10. click OK, and then click OK again.

[ ] [ ] Select Maps
Map File

Map: ‘Con(inents X Preview

J
/ Display all map features in the visualization

Compare Map and Data Values
== @ All of the values in the Data Key field have matching features.

Map Key: ' - 3
["] Save this map file and settings as the default . .
Data key: @ Continent = . 7 lﬁ{

Matched Keys: Unmatched Data Keys: Unmatched Map Keys:
Africa Oceania
Asia
Australia
Europe
North America
South America

FIGURE 13-20:

The Select
i |
Maps dialog, ®
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FIGURE 13-21:
A choropleth
of values.

Graphboard Template Chooser comes with several map files, which you can see by
clicking the Manage button. The Manage button allows you to import or export
map files. However, if you want to create your own map files, you need to use the
map conversion utility, which is in the Utility menu.

The choropleth of values map shows relationships between two categorical
variables. Note that the mode, or most common value, is depicted on the map in a
different color. Figure 13-21 illustrates the relationship between the Continent
and Product variables. The map shows that the continents of North America,
Europe, and Australia prefer Product B, the biggest seller in South America and
Africa is Product A, and Asia prefers Product C.

Mode
(Product)
W Product A
EProduct B
DOproduct ©

Coordinates on a reference map

The coordinates on a reference map uses two continuous variables, one representing
longitude and one representing latitude. A map is drawn that displays points
using longitude and latitude coordinates. This type of map can be used, for exam-
ple, to show the location of different crimes, customers, or the spread of disease.

Follow these steps to create a coordinates on a reference map:

1. choose File > Open~>Data and load the Coordinates.sav file.
Download the file at www . dummies.com/go/spssde.

2. Choose Graphs > Graphboard Template Chooser.
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3. Make sure the Basic tab is selected, and then select Longitude.
4. Hold the Ctrl key down and click the Latitude variable.

5. Sselect Coordinates on a Reference Map as the graph type.

6. Click the Detailed tab, and then click the Select a Map File button.
7. Cclick the Map drop-down list and select Continents.

8. click OK, and then click OK again.

On the reference map that appears, as shown in Figure 13-22, you can see that
most customers are located in the eastern United States and western Europe.
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FIGURE 13-22:
Coordinates on a
reference map.

Play around with different options to see what you can come up with. After all, a
good graph can easily help you convey a great deal of important information to
rRememeer  your audience.

@ We have presented just a few of the many graphs that you can create in SPSS.
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